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General Safety Summary

General Safety Summary
Review the following safety precautions to avoid injury and prevent damage to this product or any
products connected to it.

To avoid potential hazards, use this product only as specified.

Only qualified personnel should perform service procedures.

While using this product, you may need to access other parts of a larger system. Read the safety sections
of the other component manuals for warnings and cautions related to operating the system.

To Avoid Fire or Personal Injury
Connect and Disconnect Properly. Connect the probe output to the measurement instrument before
connecting the probe to the circuit under test. Connect the probe reference lead to the circuit under test
before connecting the probe input. Disconnect the probe input and the probe reference lead from the circuit
under test before disconnecting the probe from the measurement instrument.

Observe All Terminal Ratings. To avoid fire or shock hazard, observe all ratings and markings on the product.
Consult the product manual for further ratings information before making connections to the product.

Do Not Operate Without Covers. Do not operate this product with covers or panels removed.

Do Not Operate With Suspected Failures. If you suspect that there is damage to this product, have it
inspected by qualified service personnel.

Avoid Exposed Circuitry. Do not touch exposed connections and components when power is present.

Terms in this Manual
These terms may appear in this manual:

WARNING. Warning statements identify conditions or practices that could result in injury or loss of life.

CAUTION. Caution statements identify conditions or practices that could result in damage to this product or other
property.
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Introduction Using Online Help

Introduction

Using Online Help
Select Help from the menu to open the help file. You can also find an electronic copy of the help file in the
Documents directory on the 063-4068-XX DVD.

Tables of Contents (TOC) tab—Organizes the Help into book-like sections. Select a book icon to open
a section; select any of the topics listed under the book.

Index tab— Enables you to scroll a list of alphabetical keywords. Select the topic of interest to bring
up the appropriate help page.

Search tab— Allows a text-based search.

Follow these steps:

1. Type the word or phrase you want to find in the search box. If the word or phrase is not found, try the
Index tab.

2. Choose a topic in the lower box, and then select the Display button.

General Help Functions:
Select the Print button from the Help topics menu bar to print a topic.

To return to the previous window, select the Back button.

Use hyperlinks to jump from one topic to another.

If the back button is grayed out or a jump is not available, choose the Help Topics button to return to
the originating help folder.

TekExpress™ Serial ATA Automated Compliance Solutions 1



Introduction Related Documentation

Related Documentation
In addition to this TekExpress Online Help, the following documentation is included with the software:

TekExpress Installation Manual, Tektronix part number 071-2268-XX. The Installation Manual has
information about installing and upgrading the software.

TekExpress Quick Start User Manual, Tektronix part number 071-2298-XX. The Quick Start User
Manual has information about how to use the software and includes application examples.

Technical Specification documents
http://www.tek.com/Measurement/applications/serial_data/sata.html
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Introduction Conventions

Conventions
Online Help uses the following conventions:

The term “SATA” refers to Serial Advanced Technology Attachment.

The term “DUT” is an abbreviation for Device Under Test.

The term “UUT” is an abbreviation of Unit Under Test.

The term “select” is a generic term that applies to the two mechanical methods of choosing an option:
using a mouse or using the touch screen.

TekExpress™ Serial ATA Automated Compliance Solutions 3



Getting Started Technical Support

Technical Support
Tektronix values your feedback on our products. To help us serve you better, please send us your
suggestions, ideas, or comments on your application or oscilloscope.

When you contact Tektronix Technical Support, please include the following information (be as specific as
possible) :

General Information
All instrument model numbers.

Hardware options, if any.

Probes used.

Your name, company, mailing address, phone number, FAX number.

Please indicate if you would like to be contacted by Tektronix about your suggestion or comments.

Application Specific Information
Software version number

Description of the problem such that technical support can duplicate the problem.

If possible, save the setup files as .set files for all the instruments used and the application.

If possible, save the TekExpress setup files, log.xml and status messages text file.

If possible, save the waveform on which you are performing the measurement as a .wfm file.

Forward the information to technical support using one of these methods:

E-mail – techsupport@tektronix.com

FAX – (503) 627-5695
Getting Started
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Getting Started Accessories

Accessories

About the Test Fixture
The TF-SATA-NE-XP and TF-SATA-FE-XP test fixtures that facilitate SATA Compliance testing
are designed by Tektronix and manufactured and distributed by Crescent Heart Software. For more
information, visit the Crescent Heart Software Web site www.c-h-s.com.

About Frame Error Analyzer
The Crescent Heart Software SATA II probe adapter facilitates Receiver Signalling Group test. Visit
www.c-h-s.com for more information.

About Keithley Switch
The S46 Microwave Switch System is designed to simplify the automated switching needed
to test a wide range of telecommunications products and devices. For more information, visit
http://www.keithley.com/applications/aerospace/?mn=S46.

TekExpress™ Serial ATA Automated Compliance Solutions 5
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Getting Started Minimum System Requirements

Minimum System Requirements
The minimum system requirements for a PC to run TekExpress are as follows:

Table 1: System requirements
Processor Pentium 4/M or equivalent processor.
Operating System Windows XP Service Pack 2.
Memory 1 GB of memory (512 MB minimum).
Hard Disk Approximately 2 GB of available hard-disk space for the recommended

installation, which includes full TekExpress installation and distributed
components such as SQL Server Express, .NET 2.0 Framework and others.

Drive DVD drive
Display Super VGA resolution or higher video adapter (800x600 minimum video

resolution for small fonts or 1024x768 minimum video resolution for large fonts).
The application is best viewed in 96 dpi display settings.

Software Microsoft Excel 2000 or above.

Microsoft Internet Explorer 6.0 SP1 or later.

Microsoft Photo Editor 3.0 or equivalent software for image files viewing.

Adobe Reader 6.0 or equivalent software for viewing portable document
format (PDF) files.

Other Devices Microsoft compatible mouse or compatible pointing device.

Four USB port (2 USB ports minimum).

PCI-GPIB or equivalent interface for instrument connectivity 1.
1 If the TekExpress is installed on a Tektronix oscilloscope, the virtual GPIB port cannot be used by TekExpress for communicating with oscilloscope

applications.
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Getting Started Application Directories and Usage

Application Directories and Usage
Related Topics

File Name Extensions
How To Activate the License

The application directory and associated files are organized as follows:

The following table lists the default directory names and their usage:

Table 2: Default directory names and their usage
Directory names Usage
InstallDir\TekExpress Contains the application and associated files.
\TekExpress\Compliance Suites Has compliance specific sequence files. The folders

under this directory represent the devices to be
tested.

\TekExpress\Compliance Suites\Serial ATA\ The folders under this are Drive and Host.
\TekExpress\Compliance Suites\Serial ATA\Drive\
\TekExpress\Compliance Suites\Serial ATA\Host\

Typically includes the RSG folder. This represents
the suite of install tests for the drive and host
devices.

\TekExpress\ACP
\TekExpress\SCP
\TekExpress\ICP

Includes instrument and application specific
interface libraries of TekExpress.

\TekExpress\Data Manager
\TekExpress\Data Storage
\TekExpress\Report Generator

Includes the result management specific libraries of
TekExpress are present in these folders.

TekExpress™ Serial ATA Automated Compliance Solutions 7



Getting Started File Name Extensions

Table 2: Default directory names and their usage (cont.)

Directory names Usage
\TekExpress\Documents Includes the Method of Implementation documents

and technical documentation for the application.
\TekExpress\Bin
\TekExpress\Lib

Includes the Miscellaneous libraries of TekExpress.

File Name Extensions
Related Topics

Application Directories and Usage
How To Activate the License

The software uses the following file name extensions:

File name extension Description
.TekX The session file will be saved in this format.
.seq The test sequence file.
.xml 1 The encrypted XML file that contains the test specific

configuration information.
.PDF The PDF file that details the method of implementation for

the test.
1 The Log file extension is also xml.
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Getting Started How To Activate the License

How To Activate the License
Related Topics

Application Directories and Usage
File Name Extensions

Follow the below steps to activate the license:

1. Click Help > About to view the license information.

2. Click the View End-User License Agreement link to open the following Tektronix Software License
Agreement window. Click Print to take a hard copy of the License Agreement.

3. Click License Info to view the software options that are available for you to choose from. This window
shows the license key and the various options with their status (active or inactive) with the current
license key.

TekExpress™ Serial ATA Automated Compliance Solutions 9



Getting Started How To Activate the License

4. If you are activating for the first time, the license key field will be empty. To activate the license, connect
the USB dongle to your computer and enter the license key provided in the license key certificate and
click Activate. If the activation is successful, a sign is displayed next to the license key field.

5. If you are reactivating the license, click Reactivate and proceed to enter the new license key in the
license key field. Click Activate.

10 TekExpress™ Serial ATA Automated Compliance Solutions



Getting Started Before You Click Run

Before You Click Run
After you first launch TekExpress SATA.exe, TekExpress creates the following folders on your
computer:

\My Documents\My TekExpress

NOTE. If a user with a new login ID launches TekExpress SATA.exe, My TekExpress folder is created
under My Documents of the new user.

\My Documents\My TekExpress\Serial ATA

\My Documents\My TekExpress\ Serial ATA\Untitled Session. Note that everytime the
TekExpress SATA.exe is launched Untitled Session folder is created under Serial ATA

folder. The Untitled Session folder is deleted when you exit TekExpress.

NOTE. Each session has multiple files associated with it. Do not modify any of the session files and/or folders as this
may result in loss of data or corrupted session files.

Before you click Run,

1. Ensure that you have shared the My TekExpress folder described above with full access settings.

How to share My TekExpress folder
To share the My TekExpress folder follow the steps below:

a. Open Windows Explorer.

b. Select My TekExpress folder located under My Documents.

c. From Windows Explorer menu, select File > Properties. This will show the properties of the
My TekExpress folder.

d. Select Sharing tab and choose Share this folder option.

e. The default share name will be “My TekExpress”, however it is recommended to modify share
name as your login ID followed by “My TekExpress” (For example, “John’s My TekExpress”).

f. Select Permission and view the permissions. Ensure that Everyone has full control access.

g. Click Apply.

h. Select Security tab and ensure that “Everyone” has full control access.

2. Map the My TekExpress folder as X: (X drive) on the PC where TekExpress SATA is installed.

TekExpress™ Serial ATA Automated Compliance Solutions 11



Operating Basics Before You Click Run

Mapping My TekExpress folder
To map the My TekExpress folder on PC running TekExpress and on the instruments follow the
steps below:

a. Open Windows Explorer.

b. From Windows Explorer menu, select Tools > Map Network drive.

c. Select Drive letter as X: (if there is any previous connection on X:, disconnect it first through
Tools > Disconnect Network drive menu of Windows Explorer).

d. In the Folder field, enter remote My TekExpress folder path (for example, \\192.158.97.65\
John’s My TekExpress)

e. You can determine IP address of PC where “My TekExpress” folder exists by doing the
following:

Select Start > Run menu on PC where My TekExpress folder exists.

Enter cmd and click Enter.

At command prompt, type ipconfig.

3. Map the My TekExpress folder as X: (X drive) on all the instruments used in test setup running
Windows Operating System.

4. Ensure that the SATA setup files provided with install DVD are available on respective instruments.
For more details, refer to the ReadmeFirst.txt located in the SATA Setup Files folder on the
install DVD.

Operating Basics
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Operating Basics TekExpress Application Overview

TekExpress Application Overview
TekExpress is the Tektronix Compliance Test Automation Framework, developed to support current and
future test automation needs of customers. Developed using National Instruments’ TestStand, TekExpress
leverages on the capabilities of Microsoft .NET framework. It is a highly modular architecture that enables
deploying automated test solutions for various serial standards in a relatively shorter time. TekExpress
provides a compliance test automation solution for the Serial ATA Gen 1 and Gen 2 standard.

Options available with TekExpress Serial ATA are:

TSG : PHY/TSG/OOB Test Suite

RSG : Tests Suite

TxRx : Tests Suite

TekExpress SATA Bundle for the Host and Drive Test Suites

SI : Cable Tests for TekExpress SATA

TekExpress™ Serial ATA Automated Compliance Solutions 13



Operating Basics Starting the Application

Starting the Application
Related Topics

Resizing the Application Window
Exiting the Application

The application, uses a USB dongle that contains the license key. This dongle must be present on the PC or
the instrument hosting the TekExpress application.

The application also checks for a file, called Resources.xml, located in My TekExpress folder. If this file
is not found instrument discovery is performed before launching TekExpress. The Resources.xml file
contains information regarding instruments available on network.

When the application starts, it checks for the appropriate license key. If the valid license key is not present,
the application switches to the “Demo” mode. If the application fails to detect the dongle, it continues
to run in Demo mode.

To start the application, you can do one of the following:

Click Start > Programs > Tektronix > TekExpress > TekExpress SATA. Other applications follow
similar pattern.

Double click the icon on the desktop.

If you have previously saved the session, you can double-click the session file stored under My
TekExpress\Serial ATA.

When the application is launched it displays the splash screen providing launch information. The
application also checks for the presence and validity of the USB dongle.

NOTE. If the application was not terminated properly during the last use, a dialog box asks to recall the previously
unsaved session.
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Operating Basics Resizing the Application Window

Resizing the Application Window
Related Topics

Starting the Application
Exiting the Application

To minimize the application, click on the application title bar. To restore the application to its

previous size, select in the Windows task bar.

To maximize the application, click . To restore it to previous size, click on the application
title bar.

Exiting the Application
Related Topics

Starting the Application
Resizing the Application Window

To exit the application, do one of the following:

Click File > Exit.

Click on the application title bar.
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Global Controls
The menus and controls that appear outside the individual tabs are called “Global Controls”. These are
used to specify the devices to be tested.

Table 3: Controls and Functions
Control name Function
DUT The device ID is specified at the global level and the

information is stored in the default location for all data
files. This field cannot be empty and does not allow these
special characters (.,..,...,\,/:?”<>|*). The maximum length
of characters allowed is 32.
You will be able to run or stop the test at any time. When a
test is running, the button changes to Stop. When all tests
are complete, the control changes to Run again.

Operating Basics . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Menus
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Operating Basics File Menu

File Menu
Related Topics

View Menu
Tools Menu
Help Menu

Click File on the application menu bar.

The File menu has the following selections:

Menu Function
New Session Starts a default session of TekExpress.
Open Session Opens a saved session.
Save Session Saves the session.
Save Report As Saves the report in user specified location.
Print Preview Report Print preview the report.
Print Report Brings up a Windows “Print” dialog box.
Recent Sessions Lists recent sessions.
Exit Closes the application.
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Operating Basics View Menu

. . Menus . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

View Menu
Related Topics

File Menu
Tools Menu
Help Menu

Click View on the application menu bar.

The View menu has the following selections:

Menu Function
Log File This will open the log (log.xml) file in the default viewer.
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. . Menus . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Tools Menu
Related Topics

File Menu
View Menu
Help Menu

Click Tools on the application menu bar.

The Tools menu has the following selections:

Menu Function
Instrument Bench This will bring up a read-only dialog box of all the instruments attached to

the test setup.

The Instrument Bench window shows the list of VISA and Non-VISA resources found on different
interfaces/connections. It serves two purposes at the launch of TekExpress:

Discovers the connected instruments.

Confirms the instrument connection setup.

When you click Tools > Instrument Bench, the following dialog box is displayed:
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Operating Basics Tools Menu

Search Criteria : The various connections on which you can search. Non-Visa Resources are the
instruments that cannot be searched using TekVISA.

Retrieved Instruments: Displays the count and details of instruments that were discovered.

Last Updated: Displays the time when the last time search was performed.

TekVISA Refresh Timeout (Seconds): This time out specifies the maximum time that TekExpress
can wait for TekVISA update.

NOTE. TekExpress uses TekVISA for instrument search. Ensure that TekVISA is running on your system before
you refresh the instrument bench window.

Table 4: Retrieved Resources properties in the Instrument Bench window
Title Description
Connection Shows the type of connection with the instrument.
Resource Name of the resource.
Serial Number Serial number of the resource.
Options Shows the options available on the instrument. 1

Resource Address Shows IP Address/Port number of the resource.
1 The option column displays the options that fit in the field. To view complete options on the instrument, move the mouse cursor over the option.

Table 5: Button controls on Instrument Bench dialog box
Button Function
Refresh The application searches on the selected connection for resources.

While searching resources it shows the Instrument Bench discovery
window. The Discovery window shows the connection currently
being scanned and the percentage of task completed.

Close Closes the dialog box.
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. . Menus . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Help Menu
Related Topics

File Menu
View Menu
Tools Menu

Click Help on the application menu bar.

The Help menu has the following selections:

Selection Description or Function
TekExpress Help Displays TekExpress Help (F1).
About.. Displays application details such as software name, version

number and copyright.
How To
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How To Select the Test(s)

Select the Test(s)
Related Topics

View and Select Connected Instruments
Configure and Run the Tests
View the Progress of Analysis
View the Report
View Test Related Files

The application tests for two types of SATA devices for compliance.

Drive

Host

The Select panel allows you to select tests to configure and run.
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This panel provides the following functions:

Select Device
Select the Device type, and the test suite options will be updated corresponding to the device selected.

Select Test Suite
The application allows you to select a subset of tests to execute. Based on the test suite selected, the
Version drop-down list will be populated.

Version
You can select the appropriate version. For example, SATA Gen 1 or SATA Gen 2.

More/Less
The table has the following two columns:

Select: You can include or exclude any test for analysis.

Test Name: Displays the name of the test.

NOTE. If any of the check box in the Select column is grayed, you cannot make any changes. It implies that the
test is mandatory.

Once you select a row, the following options are available:

Table 6: Button controls on the Select panel
Button Description

Opens the configuration panel for the selected test.

Opens the PDF of method of implementation (MOI) for the
selected test.

Opens the schematic for the selected test. This is useful if
you want to verify the test setup before running the test.

Selects all tests in the table.

Selects all required tests in the grid and deselects all
informative tests in the table.

Deselects all tests in the table.
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How To Configure and Run the Test(s)

Configure and Run the Test(s)
Related Topics

Select the Tests

View and Select Connected Instruments

View the Progress of Analysis

View the Report

View Test Related Files

The configuration panel is used to create, view, and edit the parameters associated with the acquisition and
the analysis of the selected test.

You have the following options:

To choose between running the tests in a Compliant or User Defined mode.

To reload compliance mode values.

To change the parameters associated with the configuration of acquisition.

To change the parameters associated with analysis configuration.

The upper half of the Configure panel has general parameters that are common for all the tests under the
selected test suite that are editable. The lower half of the Configure panel has test specific parameters.

NOTE. If any of the test parameters are grayed, it means that these parameters cannot be modified in compliance
mode. When you switch to user-defined mode, these parameters are editable.
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How To Configure and Run the Test(s)

Table 7: Test parameters
Parameters to configure Description
Acquire Parameters Shows the various parameters

related to acquisition of a selected
test. These parameters can vary
from one test to another such as,
Number of Samples and Record
Length.

Analyze parameters Shows the various parameters
related to analysis of a selected
test. These parameters can vary
from one test to another such as,
Jitter values.

Test Limits Applies to a specific test. It shows
the measurement limits using
different types of comparisons.
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How To Configure and Run the Test(s)

Table 7: Test parameters (cont.)

Parameters to configure Description
Comments You can specify a comment up to

256 characters long for the selected
test.

Compliance settings
The compliance settings will be
restored.

Accepts all changes that you made.

Dismisses the dialog box and does
not apply changes.

Click Run in the Select panel to run the selected tests.

Refer to the following table for different test limit comparisons:

Table 8: Different test limit comparisons
Comparison string Description
EQ(==) Equal to
NE(!=) Not equal to
GT(>) Greater than
LT(<) Less than
GE(>=) Greater than or Equal to
LE(<=) Less than or Equal to
GTLT(><) Greater than and Less than
GELT(>=<) Greater than or equal to and Less than
GTLE(><=) Greater than and Less or equal to
LTGT(<>) Less than and Greater than
LEGE(<= >=) Less than or equal to and Greater than or equal to
LEGT(<= >) Less than or equal to and Greater than
LTGE(< >=) Less than and Greater than or equal to
GELE(>= =<) Greater than or equal to and Less than or equal to
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How To View and Select Connected Instruments

View and Select Connected Instruments
Related Topics

Select the Tests
Configure and Run the Tests
View Test Related Files
View the Progress of Analysis
View the Report

Viewing Connected Instruments
The Tools > Instrument Bench menu item is used to discover connected instruments required for the
tests. The application uses TekVISA to discover the connected instruments. Once the operation is done,
the Instrument Bench dialog box resumes operation and lists the instrument-related details based on the
selected search criteria.

NOTE. When the TekVISA Instrument Manager checks for connected Instruments, the Instrument Bench dialog box
does not respond.

For example, if you select LAN as the search criteria in the Instrument Bench dialog and click Refresh,
the TekVISA Instrument Manager checks for the instruments availability over LAN and the details of
the instrument are displayed under Retrieved Instruments table.

You can provide the time in the TekVISA Refresh Timeout (Seconds) field, within which if the TekVISA
Instrument Manager does not find the instruments, the TekExpress application resumes the operation.

If you choose Non-VISA resources, all the instruments supported by TekExpress but not communicating
over the VISA layer can be searched.
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How To View and Select Connected Instruments

Selecting Connected Instruments
You can view the instruments connected in the Configuration panel. The upper half of the panel displays
the general parameters for the tests under the selected test suite.

You can choose the instruments from the drop-down list as shown in the following figure:

NOTE. The list of instruments displayed is specific to the selected test suite. It does not show all the connected
instruments.
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How To View the Progress of Analysis

View the Progress of Analysis
Related Topics

Select the Tests
View and Select Connected Instruments
Configure and Run the Tests
View the Report
View Test Related Files

You can view the progress of the analysis in the Analyze panel. When the analysis is complete, the result
value of each test is updated.

Analysis Table
The table contains the following:

The test name.

The status of the tests that are being run.

The Tests that are not yet started are shown with a “To be Started” status. A summarized status of the
currently running test is shown on the status.
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How To View the Progress of Analysis

More/Less
The Status Messages window timestamps all runtime messages and displays them. You can do the
following:

Display Status : Enable/Disable status messages.

Auto Scroll : The status messages are scrolled automatically.

Clear All : Clear all status messages in Status Window.

Save Status : Save all status messages in text file. Displays a standard save file window and saves the
status messages in the user specified file.

NOTE. The Status Messages window is dockable and can be resized.
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How To View the Report

View the Report
Related Topics

Select the Tests
View and Select Connected Instruments
Configure and Run the Tests
View the Progress of Analysis
View Test Related Files

After analysis, a report is automatically generated and displayed in the report panel. The report shows the
results of the tests, including device information and pass/fail status of each test.

The Report View Area contains an HTML version of the report template. You can select any area of the
report and copy it to the clipboard to make it available to other application.

The View Scorecard option opens the report in Microsoft Excel.
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Pattern Generation Utility View Test Related Files

View Test Related Files
All the test related files for currently selected tests are always saved under My Documents\My

TekExpress\Serial ATA\Untitled Session.

When you save a session, it is saved with the session name under the path My Documents\My

TekExpress\Serial ATA\SessionName for future references.

The session that is currently running will be stored in the same path as “Untitled” until you save it.

NOTE. Sessions should not be saved in the name “Untitled” and “Backup” as they are application specific files and
will be deleted when the application exits.

Pattern Generation Utility
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Pattern Generation Utility Using the Pattern Generation Utility to Test Receivers

Using the Pattern Generation Utility to Test
Receivers

Related Topics
Calibration Procedure

The Pattern Generation is a utility that generates a controlled jittered waveform for performing the RSG
(Receiver Signal Gain) and RMT (Receiver Margin Testing) testing for the DUT receiver. This utility
uses a direct synthesis approach where required amounts of jitter components are added to the frame
composite. These patterns are injected to DUT using the Arbitrary Waveform Generator 7000 series with
option 2 and 6, Test fixture and matched pair cables.

Use the Calibration process (as mentioned in the MOI) to record the calibrated amplitude level, Random
Jitter, Periodic Jitter (Optimal amplitude value of) jittered frequency (which is tuned to meet the nominal
Total Jitter specified) are the inputs for the pattern generation utility.

It’s recommended to do the calibration process for each pattern generation of interest.

For the RMT tests when the DUT fails there is a need to test the DUT for range of frequencies. The
calibration has to be carried at least in the frequency resolution of 10 MHz for exact results.

Inputs to the Pattern Generation Utility
The Pattern Generation Utility is an Executable and requires you to input the following parameters (in this
order). You need to provide below inputs and there are not default values.

1. The path of the Frame composite pattern IW4R8FCP.txt. This pattern is very specific for the utility and
have known characteristics such as 10 characters per line.

2. The speed of the DUT such as usage model Gen1/Gen2.

3. Calibrated voltage swing for the utility. This is usually calculated using the 6 db attenuators at the end of
the match cables. You can refer the amplitude calibration process to measure calibrated amplitude level.

4. The calibrated Random Jitter (Rj). You can refer to the calibration procedure for more details on how to
calculate the Rj value for this setup. Rj has to specified in ps RMS.

5. Periodic Jitter (Pj) component as frequency in Hz. You can specify the frequency value between 0
to 300 MHz as ‘Start’e6 and ‘Stop’e6. The start should be less than the stop otherwise the utility
shows an error.

6. The Pj increment is in steps of 1 MHz (step given as “xxe6”) and the higher range is 300 MHz.

7. The Total jitter (Tj specified in Unit Interval (UI)) range is 0 to 1.2 UI. You have to specify the start
and stop separately as ‘Start’ and ‘Stop’ without the ‘UI’ unit. The start should be less than the stop
otherwise the utility will show an error.

8. The Tj values. These values increase in the following steps as per the Serial ATA standard. The
predefined steps are 0.01, 0.02, 0.03, 0.05 and 0.1.

9. The Amplitude Periodic jitter. You have to make sure that the amplitude periodic jitter used in the
utility to generate pattern of interest (for example 10 MHz 0.45 UI) has to result in nominal Tj value
0.45 UI. This is done by means of trial and error by recording the Tj at the output of the JIT3 Analysis –
Advanced software. Please refer to the MOI calibration procedure for more details.
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Output from the Pattern Generation Utility
The generated jittered waveform is available in the Frame composite pattern file path with file name as
<Jitter Frequency>-MHz-<TJ>UI.wfm. <Example Pj from 100 MHz to 105 MHz and Tj= 0.45 UI:
The sample file name output format is 100-MHz-0.45UI.wfm. The five AWG patterns are generated
from 100 MHz to 105 MHz.

Batch file usage
To get familiar with the usage of Serial ATA Pattern Generation Utility, an example Example_01.bat file
is provided in the location C:\SataPatternGenerationUtility after the installation.

The following are the steps to use the batch file example:

1. Double-click the Example_01.bat file.

2. The batch file gets launched and you can observe the input parameters on DOS command prompt that
is taken by the utility.

3. The jittered waveforms are generated and saved at location C:\SataPatternGenerationUtility.
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Calibration Procedure
Related Topics

Using Pattern Generation Utility to Test Receivers

To generate jittered waveforms for RSG test, the complete calibration procedure has to be followed.
Whereas, in case of generating jittered patterns for RMT test, only Random jitter calibration is required.
Calibration can be carried out using the JIT3 Analysis - Advanced software.

Random Jitter Calibration
A reference Gen1 and Gen2 MFTP waveform with zero jitter (MFTP-Rj-Cal.wfm) is provided at
c:\SataPatternGenerationUtility\Gen1MFTP folder to verify the calibration of Random jitter
(Rj). Before verifying the Rj calibration, perform an SPC calibration on the Tektronix oscilloscope hosting
the Advanced JIT3 Analysis software and perform a D/A channel calibration on the Arbitrary Waveform
Generator (AWG) to compensate for the instrument’s environmental conditions.

Rj is specified to be 0.18 UI PtP @ 7 Sigma or 4.285 ps RMS for Gen2 signaling rates and correspondingly
8.57 ps for Gen1 signaling rates.

NOTE. The Rj found in the Tektronix AWG MFTP pattern has been synthesized and is a truncated Gaussian
distribution with truncation occurring at 5 Sigma.

As illustrated in the red circled area of the preceding figure, ensure that the averaged RJ is nominally
reading 4.285 ps RMS ± 4% allowable variation 4.11 ps < Nominal Value < 4.45 ps. Analyze 16E6
contiguous points per measurement, and 3 runs will typically converge on an averaged RJ close to 4.285
ps. For Gen1 rates the nominal variation of Rj would be within 8.22 < Nominal Tj Value < 8.9. Jitter
magnitudes in excess of these values should result in recalibration of the AWG.
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If the measured value in JIT3 results does not match with nominal Rj value 4.285 ps ±4% then random
jitter component has to be varied as the input to the utility.

Perform this iteration till Rj value is close enough to nominal value specified.

Tj Calibration
Run the Pattern Generation utility using the IW4R8FCP.txt text patterns available at
c:\SataPatternGenerationUtility\IW4R8FCP.txt with calibrated random jitter value and
optimal value of the Amplitude of jittered frequency. Generate an XX-MHz -0.45UI.wfm waveform.
Analyze this waveform using JIT3 Advanced software.

Observe the averaged Total @ BER (Pk-Pk) Jitter value after three acquisitions. Adjust the amplitude of
jittered frequency value input so as to get the nominal value of Tj. The nominal accuracy of a calibrated
system will provide 0.45 UI Tj conformance within 4% of nominal error. The observed jitter for Gen2
signaling Tj should nominally be 149.9 ps of Tj ± 4% allowable variation. 144 ps < Nominal Tj Value <
155.8 ps. Jitter magnitudes in excess of these values should result in recalibration of the AWG.

For Gen1 rates, the nominal variation of a nominal value of Tj would be within 288 < Nominal Tj
Value < 312 ps.

If the measured value in the JIT3 results does not match with nominal Tj value 144 ps < Nominal Tj Value
< 155.8 ps then vary the amplitude of the periodic jitter component as the input to the utility.

Perform this iteration till Tj value is close enough to the nominal specified.

Amplitude Calibration
Signal amplitude conformance requires that Gen1 and Gen2 signaling not exceed 600 mV or 750 mV ptp
and be within 5% of a target minimum amplitude of 325 mV and 275 mV respectively. Fine adjustment
may be performed by adjusting the Vertical amplitude setting on the AWG’s CH1 output. The minimum
amplitude measurements are performed on both 212141 (negative pulse) and 413 (positive pulse) RL
patterns.

Refer to the SATA specifications (Serial ATA Revision 2.5 27-October-2005) on LBP based amplitude
measurements.

The minimum amplitude over a 1 UI epoch is the two consecutive bits at the string of a four or more
consecutive bits, which is not a representative LBP pattern but is the minimum value in Framed Composite
(Pre-ECN18) pattern.
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A 0.45 UI to 0.55 UI Histogram is setup on the two lone bits of interest from which the difference of the
mean values is computed to obtain the lone pulse amplitudes.
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Transition Time Validation
Make sure the Rise and Fall time is in the nominal range of < 100 ps. This can be verified using the JIT3
application with same setup files used for Jitter calibration/validation. Rise and Fall time measurements
allow you to validate that the transition rate does not exceed 100 ps 20/80.

After the completion of calibration process, Calibrated Voltage swing required in the jittered waveform,
Calibrated Random Jitter, Optimal value for Amplitude of jittered frequency are available and can be used
for generating waveforms for RSG and RMT tests.
Application Examples
Testing a Drive
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Equipment Setup: Drive
You need the following equipment to set up the application:

Resource Model Supported
Signal Source Tektronix AWG7102 (Option 6)
Real Time Oscilloscope Tektronix DPO/DSA 72004, DPO/DSA 71604, DPO/DSA 71254,

TDS6154C, TDS6124C

For Gen1-only testing, the following oscilloscopes are also acceptable:
DPO/DSA 70804 or TDS6804B

RF Switch Keithley S46
Frame Error Analyzer Crescent Heart Software SATA II probe adapter
Test Fixture Crescent Heart Software Fixture TF-SATA-NE-XP, TF-SATA-FE-XP
DUT A SATA Drive to test

Connect the equipments as shown in the following diagram:
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. . Testing a Drive . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Run RSG-01 - Gen1 (1.5Gb/s) Receiver
Signalling Group

Related Topics
Equipment Setup Drive
Run RMT Receiver Margin Test1

To run an RSG test on a SATA Drive to conformance standards defined by SATA-IO Interoperability,
follow these steps:

NOTE. This test is applicable for both Drive and Host devices. The test procedure is identical for both drive and host
except for a change in the connection diagram. Refer to Figure 2 for Host connection diagrams.

1. Select Drive as the device type.

2. Select RSG as the Test Suite and SATA Gen 1 as the version.

3. Enter the DUT ID in the DUT field.

4. If you want to verify the test setup before running the test(s), click Show Schematic.

5. Select RSG01-Gen1 (1.5Gb/s) Receiver Signalling Group option.

6. Click Configure to configure the test parameters. Observe that the default settings are in Compliance
mode.
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7. If you want to change the parameters, choose User Defined Mode. The message reports that the
changes made to a test may no longer be compliant.

8. You can configure any test to help you analyze measurement results. To refer to the Serial ATA
Interoperability Program Revision 1.2 Tektronix document for information on how to configure the
drive receiver tests, click Show MOI in the Select panel.

9. Click Apply to apply the new settings for the test selected. If you want to restore the default settings,
click Restore. To close the dialog box, click Close.
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10.Click Run to run the selected tests.

The status of the tests is displayed in the Analyze panel.

11. After the tests run successfully, a report is generated and displayed in the Report panel.

You can save the report using File > Save Report As option.
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. . Testing a Drive . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Run RMT- Receiver Margin Test
Related Topics

Equipment Setup Drive
Run RSG01 Gen1 1 5Gbs Receiver Signalling
Group

To run a RMT test on a Drive device, do the following:

1. Select Drive as the Device type, select RSG test suite and SATA Gen1 as the version.

2. Select RMT - Receiver Margin Test as the test to run.

3. Click Show Schematic to view the setup diagram for the application.

NOTE. Refer to the Equipment Setup: Drive section for the setup diagram.

4. For information on how to configure the RMT test parameters, refer to RSG - RMT Method of
Implementation document by clicking Show MOI.

5. Click Configure to configure the test parameters.
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6. The default settings are in User Defined Mode. Configure the Analyze parameters such as, the Start
Frequency and End Frequency. Click Apply to apply the new settings. Click Close.

7. Enter the DUT ID in the DUT field of Select panel, and click Run.

8. The progress of the Analysis is displayed in the Analyze tab.
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9. The test result report is displayed in the Report panel.

Application Examples . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Testing a Host
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Equipment Setup: Host
You need the following equipment to setup the application:

Resource Model Supported
Signal Source Tektronix AWG7102 (Option 6)
Real Time Oscilloscope Tektronix DPO/DSA 72004, DPO/DSA 71604, DPO/DSA 71254,

TDS6154C, TDS6124C

For Gen1– only testing, the following osilloscopes are also acceptable:
DPO/DSA 70804 or TDS6804B

RF Switch Keithley S46
Frame Error Analyzer Crescent Heart Software SATA II probe adapter
Test Fixture Crescent Heart Software Fixture TF-SATA-NE-XP, TF-SATA-FE-XP
DUT A SATA Host to test

Connect the equipment as shown in the following diagram:
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. . Testing a Host . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Run RSG-02 - Gen2 (3.0Gb/s) Receiver
Signalling Group

Related Topics
Equipment Setup Host

Run RMT Receiver Margin Test

To run a RSG test on a SATA Host to conformance standards defined by SATA-IO Interoperability,
follow these steps:

NOTE. The test procedure is identical for both drive and host except for a change in the connection diagram. Refer
Figure 1 for the Drive connection diagram.

1. Select Host as the device type.

2. Select RSG test suite and SATA Gen 2 as the version.

3. Enter the DUT ID in the DUT field.

4. If you want to verify the test setup before running the test(s), click Show Schematic.

5. Select RSG-02 Gen2 (3.0Gb/s) Receiver Signalling Group option.

6. Click Configure if you want to configure the test parameters. Observe that the default settings are
in Compliance mode.
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7. If you want to change the parameters, choose User Defined Mode.

8. You can configure any test to help you analyze measurement results. To refer to the Serial ATA
Interoperability Program Revision 1.2 Tektronix MOI for information on how to configure the host
receiver tests, click Show MOI in the Select panel.

9. Click Apply to apply the new settings for the selected test. If you want to restore the default settings,
click Restore. To close the dialog box, click Close.
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10.Click Run to run the selected tests. The status of the tests is displayed in the Analyze panel.
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11.After the tests run successfully, a report is generated and displayed in the Report panel.

You can save the report using File > Save Report As menu option.
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. . Testing a Host . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Run RMT- Receiver Margin Test
Related Topics

Equipment Setup Host
Run RSG02 Gen2 3 0Gbs Receiver Signalling
Group

To run an RMT test on a Host device, do the following:

1. Select Host as the Device type.

2. Select RSG test suite and SATA Gen2 as the version.

3. Select RMT - Receiver Margin Test as the test to run.

4. Click Show Schematic to view the setup diagram for the application.

NOTE. Refer to Equipment Setup: Host section, for the setup diagram.

5. For information on how to configure the RMT test parameters, refer to RSG - RMT Method of
Implementation document by clicking Show MOI.

6. Click Configure to configure the test parameters.

7. The default settings are in User Defined Mode. Configure the Analyze parameters such as, the Start
Frequency and End Frequency.
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8. Click Apply to apply the new settings. Click Close.

9. Enter the DUT ID in the DUT field. Click Run. The progress of the analysis is displayed in the
Analysis tab.
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10.The test results are displayed in the Report panel.

Troubleshooting
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Setting Correct Acquire Parameters
Related Topics

Instrument Connectivity
User Interface
TestStand Runtime Engine Installation

The TekExpress application supports various oscilloscope models for SATA compliance testing and not
all the oscilloscope models can support the same acquire parameters (combination of record length and
horizontal scale) for RSG test suite. The default settings of acquire parameters work on a majority of the
oscilloscope models, however if an incorrect combination of record length and horizontal scale is specified
then the test sequence is terminated, displaying incorrect parameter set status message.

An example for status message is as shown:

10/3/2007 10:29 AM::Writing command-HORIZONTAL:RECO 2500000

10/3/2007 10:29 AM::Set record length to-2000000

The following procedure describes how to manually identify a working combination of record length and
horizontal scale for a given oscilloscope:

1. Open Talker Listener utility of TekVisa on the oscilloscope.

2. Apply default settings on the oscilloscope by clicking Default setup on oscilloscope panel.

3. Use the oscilloscope front panel to disable channel 1 and enable channel 2 and channel 4.

4. In the Talker Listener utility, enter HORI:RECO <record length> (for example, HORI:RECO
2000000) and clickWrite.

5. Verify if the oscilloscope applied the record length that you specified in step 4. If yes, continue with
step 6 else repeat steps 2 through 4 with another record length.

6. In the Talker Listener utility, enter HORI:SCALE <horizontal scale> (for example, HORI:SCALE
10E-06) and clickWrite.

7. Verify if the oscilloscope applied the horizontal scale that you specified in step 6 and also verify that
the record length set in step 4 is not changed. If this condition is met, then you have identified
working combination of Acquire parameters. If this condition is not met, then repeat steps 2 through 6
with another combination of Acquire parameters.

Table 9: Acquire parameters for some of the oscilloscope models
Acquire parameters for RSG test suite

Oscilloscope model Record Length Horizontal Scale
TDS6154C 2000000 10E-06
TDS6804B 4000000 10E-06
DPO/DSA71254 (Firmware version 4.0.0
build 22)

5000000 10E-06

DPO/DSA72004 (Firmware version 4.0.0
build 22)

5000000 10E-06
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Instrument Connectivity
Related Topics

Setting Correct Acquire Parameters
User Interface
TestStand Runtime Engine Installation

If the instrument(s) are displayed in TekVISA Instrument Manager but not in the TekExpress Instrument
Bench, check the following:

Only those instruments that respond to *idn? and *opt? queries successfully, are displayed in
Instrument Bench.

Ensure that VXI-11 Server is running on the instruments.
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User Interface
Related Topics

Setting Correct Acquire Parameters
Instrument Connectivity
TestStand Runtime Engine Installation

The Acquire tab is disabled.

For a selected test suite, the test is performed on a live acquisition. If test(s) such as PHY-TSG-OOB can
be performed on pre-acquired waveforms, this tab is active.
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TestStand Run-time Engine Installation
Related Topics

Setting Correct Acquire Parameters
Instrument Connectivity
User Interface

Managing multiple versions of TestStand installed on the system.

TekExpress installs TestStand version 3.5 runtime engine. If you have versions other than 3.5, while
working with TekExpress, ensure that the version shipped with TekExpress is active. You can do so by
clicking Start > Programs > National Instruments > TestStand 3.5 > TestStand Version Selector.

Reference
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Shortcut Keys
The following table lists the short cut keys to access the application:

Table 10: Keyboard shortcut keys
Menu Shortcut keys
File
File Alt + F
New Session Ctrl + N
Open Session... Ctrl + O
Save Session... Ctrl + S
Save Report As... Alt + F + A
Print Preview Report Alt + F + V
Print Report... Ctrl + P
Recent Sessions Alt + F + R
Exit Ctrl + X
View
View Alt + V
Log File Ctrl + L
Tools
Tools Alt + T
Instrument Bench... Ctrl + I
Help
Help Alt + H
TekExpress Help (F1) Alt + H + H
About... Alt + H + A
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Error Codes for TekExpress
The following table lists the error codes for the application. Most of the errors require that you restart
the system.

Table 11: Error codes and Description
Error Code Description
<10000 TestStand generated error.
10001 - 11000 – Data Manager related errors
10001 Insufficient Data. The Record could not be inserted. The following

fields are empty or have insufficient data.
10002 Could not retrieve the record. The specified index is not valid.
11001 - 14000 – ICP related errors
11001 Operation mode is not set as specified.
11002 SetUp file Error: Specified SetUp file is not set.
11003 Operation state is not set as specified.
11004 Specified waveform is not loaded into channel memory.
11005 Specified channel is not enabled.
11006 Interleave State could not be set to off.
12001 Operation State is not set to required value.
12002 Display state is not set to required value.
12003 Horizontal Scale is not set to required value.
12004 Vertical scale is not set to required value.
12005 Vertical Position is not set to required value.
12006 Deskew is not set to specified value.
12007 Out of Range Error-RunTime Error Message.
14001 - 18000 – SCP related errors
14001 Timeout Error: Application could not be activated.
14002 JIT3 Application is already running.
14003 Cannot activate JIT3 application. Someother application is running

on Scope.
14004 Error recalling the specified setup.
14005 Error setting the specified Sequencer State.
14006 Error in closing the Application.
14007 Error loading the default setup.
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